summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD31
1 files changed, 16 insertions, 15 deletions
diff --git a/PKGBUILD b/PKGBUILD
index e873001aaa68..85f26ba1559d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,24 +1,25 @@
-# Generated by gem2arch (https://github.com/anatol/gem2arch)
-# Maintainer: Benjamin Chrétien <chretien dot b plus aur at gmail dot com>
+# Maintainer: Ankit R Gadiya <arch@argp.in>
+# Contributor: Benjamin Chrétien <chretien dot b plus aur at gmail dot com>
-_gemname=html-proofer
-pkgname=ruby-$_gemname
-pkgver=3.0.2
+pkgname=ruby-html-proofer
+pkgver=3.7.0
pkgrel=1
-pkgdesc='A set of tests to validate your HTML output. These tests check if your image references are legitimate, if they have alt tags, if your internal links are working, and so on. It'\''s intended to be an all-in-one checker for your documentation output.'
+pkgdesc='Test your rendered HTML files to make sure they are accurate'
arch=(any)
url='https://github.com/gjtorikian/html-proofer'
-license=(MIT)
-depends=(ruby ruby-mercenary ruby-nokogiri ruby-colored ruby-typhoeus-0 ruby-yell ruby-parallel ruby-addressable ruby-activesupport)
+license=('MIT')
+depends=('ruby' 'ruby-mercenary' 'ruby-nokogiri' 'ruby-colorize' 'ruby-typhoeus' 'ruby-yell' 'ruby-parallel' 'ruby-addressable' 'ruby-activesupport')
options=(!emptydirs)
-source=(https://rubygems.org/downloads/$_gemname-$pkgver.gem)
-noextract=($_gemname-$pkgver.gem)
-sha1sums=('66ae85ec941720fb8b6fdd9bc2774a68579e22e3')
+source=("https://rubygems.org/downloads/html-proofer-${pkgver}.gem"
+ "LICENSE")
+noextract=("html-proofer-${pkgver}.gem")
+sha1sums=('fd804e5b09f77353cf5661e13453e719849ed860'
+ 'f90727a909db39508bcfdcfff6e9c225a295dc8a')
package() {
- local _gemdir="$(ruby -e'puts Gem.default_dir')"
- gem install --ignore-dependencies --no-user-install -i "$pkgdir/$_gemdir" -n "$pkgdir/usr/bin" $_gemname-$pkgver.gem
- rm "$pkgdir/$_gemdir/cache/$_gemname-$pkgver.gem"
+ local _gemdir="$(ruby -e'puts Gem.default_dir')"
+ gem install --ignore-dependencies --no-user-install -i "${pkgdir}/${_gemdir}" -n "${pkgdir}/usr/bin" "html-proofer-${pkgver}.gem"
+ rm "${pkgdir}/${_gemdir}/cache/html-proofer-${pkgver}.gem"
- chmod a+x "$pkgdir/usr/bin/htmlproofer"
+ install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}