summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD25
1 files changed, 25 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4203aeceeea1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: OmeGa <omega [U+0040] mailoo [.] org>
+
+pkgname=ruby-httpclient-2.6
+_gemname=httpclient
+pkgver=2.6.0.1
+pkgrel=1
+pkgdesc="Gives something like the functionality of libwww-perl (LWP) in Ruby."
+arch=('any')
+url="http://github.com/nahi/httpclient"
+license=('Ruby')
+depends=('ruby')
+makedepends=('rubygems')
+conflicts=('ruby-httpclient')
+source=(http://rubygems.org/downloads/$_gemname-$pkgver.gem)
+noextract=($_gemname-$pkgver.gem)
+sha1sums=('f6a18094e9d1154a9c90df90aa2c8518f3837863')
+
+package() {
+ cd "$srcdir"
+ local _gemdir="$(ruby -rubygems -e'puts Gem.default_dir')"
+ gem install --no-user-install --ignore-dependencies -i \
+ "$pkgdir$_gemdir" $_gemname-$pkgver.gem
+}
+
+# vim:set ts=2 sw=2 et: