summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD40
1 files changed, 20 insertions, 20 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 95a711afcfab..ce2b3285d612 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,4 +1,5 @@
-# Maintainer: Henrik Hodne <henrik@hodne.io>
+# Contributor: Henrik Hodne <henrik@hodne.io>
+# Maintainer: Dennis Schubert <mail@dennis-schubert.de>
pkgname=ruby-install
pkgver=0.6.0
@@ -10,32 +11,31 @@ license=('MIT')
depends=('bash')
optdepends=('zsh')
makedepends=('gnupg')
-source=(https://github.com/postmodern/${pkgname}/archive/v${pkgver}.tar.gz)
+source=("https://github.com/postmodern/${pkgname}/archive/v${pkgver}.tar.gz")
sha256sums=('3cc90846ca972d88b601789af2ad9ed0a496447a13cb986a3d74a4de062af37d')
prepare() {
- if gpg --fingerprint 0xB9515E77 >/dev/null 2>&1; then
- # Download key
- msg "Downloading package signature"
- curl -L -o ${pkgname}-${pkgver}.tar.gz.asc https://raw.github.com/postmodern/${pkgname}/master/pkg/${pkgname}-${pkgver}.tar.gz.asc -s
+ if gpg --fingerprint 0xB9515E77 >/dev/null 2>&1; then
+ # Download key
+ msg "Downloading package signature"
+ curl -L -o ${pkgname}-${pkgver}.tar.gz.asc https://raw.github.com/postmodern/${pkgname}/master/pkg/${pkgname}-${pkgver}.tar.gz.asc -s
- # Check key
- if gpg --verify ${pkgname}-${pkgver}.tar.gz.asc ${srcdir}/v${pkgver}.tar.gz; then
- msg "Verification of package was successful."
- else
- msg "Verification of package failed. Please check yourself with:"
- echo "gpg --verify ${pkgname}-${pkgver}.tar.gz.asc ${srcdir}/v${pkgver}.tar.gz"
- fi
+ # Check key
+ if gpg --verify ${pkgname}-${pkgver}.tar.gz.asc ${srcdir}/v${pkgver}.tar.gz; then
+ msg "Verification of package was successful."
else
- printf "\n\n"
- msg "Please import the gpg key of the ruby-install author, to check package integrity:"
- msg "https://postmodern.github.io/contact.html#pgp"
- printf "\n\n"
+ msg "Verification of package failed. Please check yourself with:"
+ echo "gpg --verify ${pkgname}-${pkgver}.tar.gz.asc ${srcdir}/v${pkgver}.tar.gz"
fi
+ else
+ printf "\n\n"
+ msg "Please import the gpg key of the ruby-install author, to check package integrity:"
+ msg "https://postmodern.github.io/contact.html#pgp"
+ printf "\n\n"
+ fi
}
package() {
- cd "$srcdir/$pkgname-$pkgver"
-
- make PREFIX="${pkgdir}/usr" install
+ cd "$srcdir/$pkgname-$pkgver"
+ make PREFIX="${pkgdir}/usr" install
}