summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD13
1 files changed, 8 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 63d984fd2719..1d1d5a23a25d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,14 +8,17 @@ pkgdesc='Ruby implementation of http://goessner.net/articles/JsonPath'
arch=('any')
url='https://github.com/joshbuddy/jsonpath'
license=('MIT')
-depends=('ruby' 'ruby-multi_json')
+depends=('ruby-multi_json')
options=('!emptydirs')
-source=("https://rubygems.org/downloads/$_gemname-$pkgver.gem")
-noextract=('$_gemname-$pkgver.gem')
-md5sums=('b5dd754e81ad2ee39f92e511f50d7ef3')
+source=("${pkgname}-${pkgver}.gem::https://rubygems.org/downloads/$_gemname-$pkgver.gem"
+ 'LICENSE::https://github.com/joshbuddy/jsonpath/raw/master/LICENSE.md')
+noextract=("${pkgname}-${pkgver}.gem")
+sha256sums=('4c7282006de383fb62d8a092e6bec6e7ebfc0b899ad59349a279bc32c76bfb9e'
+ 'f8d08617b73c9c304c8543b9b87e354e02468bd02982ae4406283e7a6e29ec02')
package() {
local _gemdir="$(ruby -e'puts Gem.default_dir')"
- gem install --ignore-dependencies --no-user-install -i "$pkgdir/$_gemdir" -n "$pkgdir/usr/bin" $_gemname-$pkgver.gem
+ gem install --ignore-dependencies --no-user-install -i "$pkgdir/$_gemdir" -n "$pkgdir/usr/bin" ${pkgname}-${pkgver}.gem
rm "$pkgdir/$_gemdir/cache/$_gemname-$pkgver.gem"
+ install -Dm644 "${srcdir}/LICENSE" -t "${pkgdir}/usr/share/licenses/${pkgname}"
} \ No newline at end of file