summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD7
1 files changed, 3 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 31b6d6b4bb18..7b8e71c0f3e8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,14 +6,13 @@
_gemname="sprockets-rails"
pkgname="ruby-${_gemname}"
pkgver=3.2.2
-pkgrel=2
+pkgrel=3
pkgdesc='Sprockets Rails integration'
arch=('any')
url='https://github.com/rails/sprockets-rails'
license=('MIT')
options=(!emptydirs)
depends=('ruby' 'ruby-actionpack' 'ruby-activesupport' 'ruby-sprockets')
-makedepends=('ruby-bundler' 'ruby-rails' 'ruby-rake')
source=("${pkgname}-${pkgver}.tar.gz::https://github.com/rails/sprockets-rails/archive/v${pkgver}.tar.gz")
sha512sums=('048f48930325316ac28d721a2c33ba60767dfec9456b0705e90363a1c81c8876ec6f99d65ce533d5a0704e1f67a33fcac5cd675aec5cc3c3f1cd896d518865a9')
@@ -27,7 +26,7 @@ prepare() {
build() {
cd "${_gemname}-${pkgver}"
- rake build
+ gem build "${_gemname}.gemspec"
}
# test have been disabled for now: https://github.com/rails/sprockets-rails/issues/473
@@ -42,7 +41,7 @@ package() {
local _gemdir="$(gem env gemdir)"
- gem install --ignore-dependencies --no-user-install --install-dir "${pkgdir}/${_gemdir}" --bindir "${pkgdir}/usr/bin" "pkg/${_gemname}-${pkgver}.gem"
+ gem install --ignore-dependencies --no-user-install --install-dir "${pkgdir}/${_gemdir}" --bindir "${pkgdir}/usr/bin" "${_gemname}-${pkgver}.gem"
rm "${pkgdir}/${_gemdir}/cache/${_gemname}-${pkgver}.gem"