summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD26
1 files changed, 26 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..cdfa18ce9c5c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Andy Weidenbaum <archbaum@gmail.com>
+
+pkgname=ruby-vimdeck
+pkgver=0.2.9
+pkgrel=1
+pkgdesc="VIM as a presentation tool"
+arch=('any')
+url="https://github.com/tybenz/vimdeck"
+license=('MIT')
+depends=('ruby' 'ruby-artii' 'ruby-asciiart' 'ruby-redcarpet')
+optdepends=('vim-syntaxrange-git: SyntaxRange plugin must be installed')
+source=("https://rubygems.org/downloads/${pkgname#*-}-${pkgver}.gem")
+sha256sums=('85767bbc67720ceb3d3e4b674795503433cde4e10f726fae00db7e4dc8a10ff5')
+noextract=("${pkgname#*-}-${pkgver}.gem")
+provides=('ruby-vimdeck' 'vimdeck')
+conflicts=('vimdeck')
+
+package() {
+ cd "$srcdir"
+
+ gem install \
+ --no-user-install \
+ --ignore-dependencies \
+ -i "$pkgdir$(ruby -rubygems -e'puts Gem.default_dir')" \
+ ${pkgname#*-}-$pkgver.gem
+}