summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD32
1 files changed, 32 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5971c2547fbe
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer:
+# Contributor: Sven-Hendrik Haase <sh@lutzhaase.com>
+# Contributor: Sergey Shatunov <me@prok.pw>
+# Contributor: Jonne Haß <me@jhass.eu>
+
+_rubyver=2.5
+_gemname=bundler
+pkgname=ruby${_rubyver}-${_gemname}
+pkgver=2.1.4
+pkgrel=1
+pkgdesc="Manages an application's dependencies through its entire life, across many machines, systematically and repeatably."
+arch=('any')
+url="http://bundler.io"
+license=('MIT')
+depends=('ruby2.5')
+options=('!emptydirs')
+source=("https://rubygems.org/downloads/$_gemname-$pkgver.gem")
+noextract=("$_gemname-$pkgver.gem")
+sha512sums=('6c870061a78e17d97a9219433c7ef8fbf1112de17d0e0f3d8b6db1a518318528e3803184278412aabe65008e93f451ffa59465062856918ef488f9438399eff6')
+
+package() {
+ cd "$srcdir"
+
+ local _gemdir="$(ruby-${_rubyver} -e'puts Gem.default_dir')"
+ HOME="/tmp" GEM_HOME="$_gemdir" GEM_PATH="$_gemdir" gem-${_rubyver} install --no-user-install --ignore-dependencies \
+ --no-ri --no-rdoc -i "$pkgdir/$_gemdir" "$_gemname-$pkgver.gem"
+ rm "$pkgdir/$_gemdir/cache/$_gemname-$pkgver.gem"
+ install -D -m644 "$pkgdir/$_gemdir/gems/$_gemname-$pkgver/LICENSE.md" "$pkgdir/usr/share/licenses/$pkgname/LICENSE.md"
+
+ install -d "$pkgdir/usr/bin/"
+ ln -s "$_gemdir/bin/bundle" "$pkgdir/usr/bin/bundle-${_rubyver}"
+}