summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD44
1 files changed, 44 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3ccb1321933f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,44 @@
+# Maintainer: Qirui Wang <wqr.prg@gmail.com>
+
+_name=rumur
+pkgname="$_name-git"
+pkgver=2019.03.11.r11.g9626824
+pkgrel=1
+pkgdesc="Yet another Murphi model checker"
+arch=('x86_64')
+url="https://github.com/Smattr/rumur"
+license=('custom')
+depends=('gmp')
+makedepends=('git' 'cmake' 'bison' 'flex' 'bison' 'flex')
+provides=("$_name")
+conflicts=("$_name")
+source=("git+https://github.com/Smattr/$_name.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/$_name"
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g;s/^v//'
+}
+
+prepare() {
+ mkdir -p $_name/build
+}
+
+build() {
+ cd $_name/build
+ cmake .. \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_INSTALL_LIBDIR=/usr/lib
+ make
+}
+
+check() {
+ cd $_name/build
+ ../tests/integration-tests.py --verbose
+}
+
+package() {
+ cd $_name/build
+ make DESTDIR="$pkgdir" install
+ install -Dm644 ../LICENSE "$pkgdir/usr/share/licenses/$pkgname/licence"
+}