summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD5
1 files changed, 3 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 71d8bfef2a1d..3322234118fc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
# Contributor: ask
pkgname=rust-bindgen-git
-pkgver=0.25.0.18b7e62
+pkgver=0.28.0.23dbe48
pkgrel=1
pkgdesc="Binding generator for rust language"
arch=('i686' 'x86_64')
@@ -16,7 +16,8 @@ sha512sums=('SKIP')
pkgver() {
cd "$srcdir/rust-bindgen"
- printf "%s.%s" "`grep version Cargo.toml | sed "s/version\ = \"\([^\"]\+\)\"/\1/"`" "$(git log --pretty=format:%h --abbrev-commit -n1)"
+ version=`grep version Cargo.toml -h --color=never | head -n 1 | sed "s/version = \"\([^\n]\+\)\"/\1/"`
+ printf "%s.%s" "$version" "$(git log --pretty=format:%h --abbrev-commit -n1)"
}
build() {