summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD9
1 files changed, 5 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 80e892c0aaca..71d8bfef2a1d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,19 +3,20 @@
# Contributor: ask
pkgname=rust-bindgen-git
-pkgver=0.14.0.ba150d9
+pkgver=0.25.0.18b7e62
pkgrel=1
pkgdesc="Binding generator for rust language"
arch=('i686' 'x86_64')
-url="https://github.com/crabtw/rust-bindgen"
+url="https://github.com/servo/rust-bindgen"
license=('BSD')
makedepends=('rust')
-source=('git://github.com/crabtw/rust-bindgen.git')
+depends=('clang>=4.0.0')
+source=('git://github.com/servo/rust-bindgen.git')
sha512sums=('SKIP')
pkgver() {
cd "$srcdir/rust-bindgen"
- printf "%s.%s" "$(grep version Cargo.toml | cut -c12-17)" "$(git log --pretty=format:%h --abbrev-commit -n1)"
+ printf "%s.%s" "`grep version Cargo.toml | sed "s/version\ = \"\([^\"]\+\)\"/\1/"`" "$(git log --pretty=format:%h --abbrev-commit -n1)"
}
build() {