summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD31
1 files changed, 31 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e0a8537aadb4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Vlad M. <vlad@archlinux.net>
+
+pkgname=rusti-git
+_pkgname=rusti
+pkgver=r121.13b5940
+pkgrel=1
+pkgdesc="REPL for the Rust"
+url="https://github.com/murarth/rusti"
+depends=('rust')
+makedepends=('git' 'cargo')
+provides=('rusti')
+conflicts=('rusti')
+arch=('i686' 'x86_64')
+license=('Apache' 'MIT')
+source=("git+https://github.com/murarth/$_pkgname.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "$_pkgname"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd "$_pkgname"
+ cargo build --release
+}
+
+package() {
+ install -Dm755 "$srcdir/$_pkgname/target/release/$_pkgname" "$pkgdir/usr/bin/$_pkgname"
+ install -Dm644 "$srcdir/$_pkgname/"{LICENSE-APACHE,LICENSE-MIT} "$pkgdir/usr/share/licenses/$pkgname/"
+}