summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD41
1 files changed, 23 insertions, 18 deletions
diff --git a/PKGBUILD b/PKGBUILD
index f510523d22e5..5848c976963a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,28 +1,32 @@
# Maintainer: Lukas Tobler <luk4s.tobler@gmail.com>
-pkgname=rxvt-unicode-256xresources
+
_pkgname=rxvt-unicode
+pkgname=rxvt-unicode-256xresources
pkgver=9.21
-pkgrel=1
-pkgdesc="urxvt with support for 256 Xresource colors and patches for line/font spacing"
-arch=('i686' 'x86_64' 'armv6h' 'armv7h')
+pkgrel=2
+pkgdesc="urxvt with patches to support 256 Xresource colors and fixes for line/font spacing"
+arch=('i686' 'x86_64')
url="http://software.schmorp.de/pkg/rxvt-unicode.html"
license=('GPL')
-depends=('gcc-libs' 'libxft' 'gdk-pixbuf2')
-optdepends=('perl: lots of utilities' 'gtk2-perl: to use the urxvt-tabbed')
+depends=('libxft' 'perl' 'startup-notification' 'rxvt-unicode-terminfo')
+optdepends=('gtk2-perl: to use the urxvt-tabbed')
source=(http://dist.schmorp.de/rxvt-unicode/$_pkgname-$pkgver.tar.bz2
font-width-fix.patch
line-spacing-fix.patch
256color.patch
urxvt.desktop
- urxvtc.desktop)
+ urxvtc.desktop
+ urxvt-tabbed.desktop)
provides=(rxvt-unicode)
conflicts=(rxvt-unicode)
md5sums=('a9a06c608258c5fd247c3725d8f44582'
'df0c3a8b6bb0578d1b91e4081c47881c'
'd4e03127a0d3bbf2e173850770651b08'
'fb78c2ecf87626962734320cc2bb7ab1'
- '88d8786d74b819450adf722180db09fd'
- 'bebf5b6b399b74b557fcedbdb47cc387')
+ 'fec94dc986fa37ec380079d81de3e0b2'
+ 'fac55f0a8404c86dad3e702146762332'
+ '8a5599197568c63720e282b9722a7990'
+ )
build() {
cd "$srcdir/$_pkgname-$pkgver"
patch -p0 -i ../256color.patch
@@ -60,18 +64,19 @@ build() {
}
package() {
- cd "$srcdir/$_pkgname-$pkgver"
- install -d "$pkgdir/usr/share/terminfo"
- export TERMINFO="$pkgdir/usr/share/terminfo"
+ #install freedesktop menu
+ for _f in urxvt urxvtc urxvt-tabbed; do
+ install -Dm644 $_f.desktop "$pkgdir/usr/share/applications/$_f.desktop"
+ done
+
+ cd $_pkgname-$pkgver
+
+ #workaround terminfo installation
+ export TERMINFO="$srcdir/terminfo"
+ install -d "$TERMINFO"
make DESTDIR="$pkgdir" install
#install the tabbing wrapper ( requires gtk2-perl! )
sed -i 's/\"rxvt\"/"urxvt"/' doc/rxvt-tabbed
install -Dm 755 doc/rxvt-tabbed "$pkgdir/usr/bin/urxvt-tabbed"
-
- #install freedesktop menu
- install -Dm644 ../urxvt.desktop \
- "$pkgdir/usr/share/applications/$urxvt.desktop"
- install -Dm644 ../urxvtc.desktop \
- "$pkgdir/usr/share/applications/$urxvtc.desktop"
}