summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 7 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 6342dc0b477e..739cca85683f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,7 +8,7 @@
_pkgname=rxvt-unicode
pkgname=rxvt-unicode-patched
pkgver=9.22
-pkgrel=2
+pkgrel=3
pkgdesc='Unicode enabled rxvt-clone terminal emulator (urxvt) with fixed font spacing'
arch=('i686' 'x86_64')
url='http://software.schmorp.de/pkg/rxvt-unicode.html'
@@ -23,14 +23,16 @@ source=(http://dist.schmorp.de/rxvt-unicode/$_pkgname-$pkgver.tar.bz2
'urxvt-tabbed.desktop'
'font-width-fix.patch'
'line-spacing-fix.patch'
- 'https://gist.githubusercontent.com/alexoj/df5bae7a4825cb596581/raw/75a1e75c2ae1ec5c0db68a29f8a6821e9e3d87a5/sgr-mouse-mode.patch')
+ 'https://gist.githubusercontent.com/alexoj/df5bae7a4825cb596581/raw/75a1e75c2ae1ec5c0db68a29f8a6821e9e3d87a5/sgr-mouse-mode.patch'
+ 'enable-wide-glyphs.patch')
sha1sums=('e575b869782fbfed955f84f48b204ec888d91ba1'
'b5a4507f85ebb7bac589db2e07d9bc40106720d9'
'62c4ffecfce6967def394dd4d418b68652372ea2'
'cd204d608d114d39c80331efe0af0231ad6b7e18'
'01ee8f212add79a158dcd4ed78d0ea1324bdc59b'
'b7fde1c46af45e831828738874f14b092b1e795f'
- 'dfbc8729c545105eff21e20ef3a4a3841a68a192')
+ 'dfbc8729c545105eff21e20ef3a4a3841a68a192'
+ '59f5c5838c6f49521527146053eb439d96a25179')
prepare() {
cd $_pkgname-$pkgver
@@ -38,6 +40,7 @@ prepare() {
patch -p0 -i ../font-width-fix.patch
patch -p0 -i ../line-spacing-fix.patch
patch -p0 -i ../sgr-mouse-mode.patch
+ patch -p1 -i ../enable-wide-glyphs.patch
}
build() {
@@ -66,6 +69,7 @@ build() {
--enable-transparency \
--enable-unicode3 \
--enable-utmp \
+ --enable-wide-glyphs \
--enable-wtmp \
--enable-xft \
--enable-xim \