summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD19
1 files changed, 12 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 15ad4ff7e6ce..9a2f8f1efb04 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@ _name=Ryujinx
pkgname=ryujinx
pkgver=1.1.458
_commit=459c4caebac0bc16c04467d9dcd2ef7a9fc0bd92
-pkgrel=1
+pkgrel=2
pkgdesc="Experimental Nintendo Switch Emulator written in C#"
arch=(x86_64)
url="https://github.com/Ryujinx/Ryujinx"
@@ -12,7 +12,7 @@ license=('MIT')
depends=('dotnet-runtime')
makedepends=('dotnet-sdk' 'git' 'html2text')
provides=($_name)
-conflicts=($pkgname-git)
+conflicts=($_name)
options=(!strip)
source=("git+$url#commit=$_commit"
"$url/wiki/Changelog")
@@ -21,16 +21,21 @@ b2sums=('SKIP'
pkgver() {
cd $_name
-
_commit_msg=$(git log -1 --pretty=%B | awk '{$NF=""}1') # remove PR number in parentheses
html2text ../Changelog | grep -B 4 "${_commit_msg::length - 1}" | head -n 1 | awk '{print $2}'
}
build() {
cd $_name
-
- dotnet publish --nologo -c Release -r linux-x64 -p:DebugType=embedded --self-contained true Ryujinx
- dotnet publish --nologo -c Release -r linux-x64 -p:DebugType=embedded --self-contained true Ryujinx.Ava
+ _args="-c Release \
+ --nologo \
+ -p:DebugType=embedded \
+ -p:ExtraDefineConstants=DISABLE_UPDATER \
+ -p:Version=$pkgver \
+ -r linux-x64 \
+ --self-contained true"
+ dotnet publish $_args Ryujinx
+ dotnet publish $_args Ryujinx.Ava
}
package() {
@@ -49,5 +54,5 @@ package() {
install -Dm644 distribution/linux/ryujinx-logo.svg "$pkgdir/usr/share/icons/hicolor/scalable/apps/ryujinx.svg"
install -Dm644 distribution/linux/ryujinx-mime.xml "$pkgdir/usr/share/mime/packages/ryujinx-mime.xml"
- install -dm777 "$pkgdir/opt/ryujinx/Logs"
+ install -dm777 "$pkgdir/opt/ryujinx/Logs" # create writable logs directory
}