summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD32
1 files changed, 32 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..507cd1982ff4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Santiago Torres-Arias <santiago@archlinux.org>
+pkgname=safetynets-git
+pkgver=d193964
+pkgrel=1
+pkgdesc="A framework to outsource machine-learning inference to "
+arch=("x86_64" "i686")
+url="https://github.com/zghodsi/safetynests"
+license=('custom:CC-BY-NC')
+depends=()
+source=("git+https://github.com/zghodsi/safetynets")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd safetynets
+ git log -n1 --format=%h
+}
+
+build() {
+ cd safetynets
+ make
+}
+
+check() {
+ cd safetynets
+ ./safetynets.o timit_arch.txt
+}
+
+package() {
+ install -Dm755 "${srcdir}/safetynets/safetynets.o" "${pkgdir}/usr/bin/safetynets"
+}
+
+# vim:set ts=2 sw=2 et: