summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD20
1 files changed, 20 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4f3662df7a44
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,20 @@
+# Maintainer: Alexander F Rødseth <xyproto@archlinux.org>
+
+pkgname=sakemake
+pkgver=0.4
+pkgrel=1
+pkgdesc='Simple way to build your C++17 executables on Linux'
+arch=('x86_64')
+url='https://github.com/xyproto/sakemake'
+license=('MIT')
+makedepends=('git')
+depends=('make' 'scons' 'clang' 'gcc' 'pkg-config')
+source=("git+https://github.com/xyproto/sakemake#tag=$pkgver")
+md5sums=('SKIP')
+
+package() {
+ PREFIX="$pkgdir" make -C $pkgname install
+ install -Dm644 $pkgname/LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}
+
+# vim: ts=2 sw=2 et: