summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD17
1 files changed, 11 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 9be139904cdc..60419be54f84 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,16 +1,16 @@
# Maintainer: bipin kumar <bipin@ccmb.res.in>
pkgname=salmon
pkgver=1.9.0
-pkgrel=1
+pkgrel=2
pkgdesc="Highly-accurate & wicked fast transcript-level quantification from RNA-seq reads using lightweight alignments"
arch=('x86_64')
url="https://combine-lab.github.io/$pkgname/"
-license=('GPL v3.0')
-depends=('bzip2' 'intel-tbb' 'xz')
-makedepends=('boost>=1.55' 'cmake' 'unzip')
+license=('GPL')
+depends=('intel-tbb' 'jemalloc' 'boost-libs' 'bzip2')
+makedepends=('boost>=1.55' 'cmake' 'unzip' 'cereal')
options=('!emptydirs')
source=("$pkgname-$pkgver.tar.gz"::"https://github.com/COMBINE-lab/$pkgname/archive/v$pkgver.tar.gz")
-md5sums=('8bdb73fbda5209953d6c480a67f52a9f')
+sha256sums=('450d953a5c43fe63fd745733f478d3fbaf24d926cb52731fd38ee21c4990d613')
prepare() {
cd "$pkgname-$pkgver"
@@ -20,7 +20,6 @@ prepare() {
}
build() {
-
cd "$pkgname-$pkgver"
# FIXME: NO_IPO=TRUE is for some reason needed in 1.3.0
@@ -31,6 +30,7 @@ build() {
-DCMAKE_COLOR_MAKEFILE:BOOL='ON' \
-DCMAKE_INSTALL_PREFIX:PATH='/usr' \
-Wno-dev \
+ -DUSE_SHARED_LIBS=ON \
.
make
@@ -39,6 +39,11 @@ build() {
package() {
cd "$pkgname-$pkgver"
make DESTDIR="$pkgdir" install
+
+ install -Dm644 include/{*.h,*.hpp,*.tpp} -t ${pkgdir}/usr/include/${pkgname}
+
+ # clear cmake files
+ rm -rf ${pkgdir}/usr/lib/{graphdump,ntcard,twopaco}
}
# Local Variables: