summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD14
1 files changed, 11 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 03ebce136d9f..28c8cea7e3f2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,4 +1,5 @@
# Maintainer: zer0def <zer0def@github>
+# Contributor: Kirill Goncharov <kdgoncharov cat gmail dog com>
# Contributor: Johannes Löthberg <johannes@kyriasis.com>
# Contributor: SĂ©bastien Luttringer
# Contributor: Daniel Wallace <danielwallace at gtmanfred dot com>
@@ -6,7 +7,7 @@
pkgname=salt-py3
pkgver=2019.2.3
-pkgrel=1
+pkgrel=2
pkgdesc='Central system and configuration manager'
arch=('any')
@@ -36,10 +37,17 @@ backup=('etc/logrotate.d/salt'
install=salt.install
source=("https://pypi.io/packages/source/s/salt/salt-$pkgver.tar.gz"
- salt.logrotate)
+ salt.logrotate
+ "0001-saltssh-py38.patch")
sha256sums=('7497e7dbfd4dc3799bbbc8da63da98b8301bbb644150f3905fe5775a7d81271a'
- 'abecc3c1be124c4afffaaeb3ba32b60dfee8ba6dc32189edfa2ad154ecb7a215')
+ 'abecc3c1be124c4afffaaeb3ba32b60dfee8ba6dc32189edfa2ad154ecb7a215'
+ 'e91791b6431ba56ff5ba0b0ff4ae1fba7335fa358698e12829daf2c248c1568d')
+
+prepare() {
+ cd salt-$pkgver
+ patch -p1 < ../0001-saltssh-py38.patch
+}
build() {
cd salt-$pkgver