summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD20
1 files changed, 17 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index f953e3cb03f1..27a485954cab 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=sanoid
pkgver=1.4.14
-pkgrel=1
+pkgrel=2
pkgdesc="Sanoid is a policy-driven snapshot management tool for ZFS filesystems."
arch=('any')
url='https://github.com/jimsalterjrs/sanoid'
@@ -14,17 +14,31 @@ optdepends=('pv: progress bars'
'mbuffer: stream buffering')
conflicts=('sanoid-git')
provides=('sanoid')
-source=("$pkgname-$pkgver.tar.gz::https://github.com/jimsalterjrs/sanoid/archive/v$pkgver.tar.gz")
+source=("$pkgname-$pkgver.tar.gz::https://github.com/jimsalterjrs/sanoid/archive/v$pkgver.tar.gz"
+ 'sanoid.service'
+ 'sanoid.timer')
-sha256sums=('7425e54622f7f270d9a5c3ac4e814e20d2df5307b5e032feb4a6d023a659d516')
+sha256sums=('7425e54622f7f270d9a5c3ac4e814e20d2df5307b5e032feb4a6d023a659d516'
+ 'a1f53363c2814a797ed4b19533b31db87e36bf9ffd41487c036570e80f498f76'
+ '69f216772f852e2f7ed90633799d2ad8fa04cb0166c2e54eddcf6654047a4beb')
package() {
cd "${pkgname}-${pkgver}"
+
+ # Documents
install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/sanoid/LICENSE"
install -Dm644 README.md "${pkgdir}/usr/share/doc/sanoid/LICENSE"
+
+ # Configs
install -Dm644 sanoid.conf "${pkgdir}/etc/sanoid/sanoid.conf"
install -Dm644 sanoid.defaults.conf "${pkgdir}/etc/sanoid/sanoid.defaults.conf"
+
+ # Binaries
install -Dm755 sanoid "${pkgdir}/usr/bin/sanoid"
install -Dm755 syncoid "${pkgdir}/usr/bin/syncoid"
install -Dm755 findoid "${pkgdir}/usr/bin/findoid"
+
+ # systemd
+ install -D -m 644 "${srcdir}/sanoid.timer" "${pkgdir}/usr/lib/systemd/system/sanoid.timer"
+ install -D -m 644 "${srcdir}/sanoid.service" "${pkgdir}/usr/lib/systemd/system/sanoid.service"
}