summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD37
1 files changed, 37 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5b5f67ac0659
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# NOTE: Please fill out the license field for your package! If it is unknown,
+# then please put 'unknown'.
+
+# Maintainer: Vincent Bidard de la Noƫ vincentbidarddelanoe@gmail.com
+pkgname="sasm-asm-git"
+pkgver="0.2"
+pkgrel=1
+pkgdesc="A compiler of sasm, an assembly-like language that compile to assembly."
+arch=('any')
+url="https://github.com/Vinz2008/Sasm"
+license=('GPL')
+makedepends=("git")
+depends=("nasm")
+sha256sums=('SKIP')
+install=
+changelog=
+source=("sasm-asm::git+https://github.com/vinz2008/Sasm.git")
+noextract=()
+
+
+build() {
+ echo ${srcdir}
+ cd ${srcdir}/sasm-asm
+ make
+}
+
+check() {
+ cd ${srcdir}/sasm-asm
+ make test
+ ./sasm-tests
+}
+
+package() {
+ mkdir -p "${pkgdir}/usr/bin"
+ cp "${srcdir}/sasm-asm/sasm" "${pkgdir}/usr/bin/sasm"
+ chmod a+x "${pkgdir}/usr/bin/sasm"
+}