summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD40
1 files changed, 40 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7b36c3211d2d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,40 @@
+# $Id$
+# Maintainer: Timo Sarawinski <timo@muhviehstarr.de>
+# Original TU: Jeff Mickey <j@codemac.net>
+# Patch by devttys0
+# Contributor: ciccio.a
+
+pkgname=sasquatch
+_origpkgname=squashfs-tools
+pkgver=4.3
+pkgrel=4
+pkgdesc="Tools for squashfs, a highly compressed read-only filesystem for Linux."
+url="https://github.com/devttys0/sasquatch"
+license=("GPL")
+arch=('i686' 'x86_64')
+depends=('zlib' 'lzo' 'xz' 'lz4')
+source=("http://downloads.sourceforge.net/sourceforge/squashfs/squashfs${pkgver}.tar.gz"
+ "patch0.txt.gz"
+ "Makefile")
+md5sums=('d92ab59aabf5173f2a59089531e30dbf'
+ 'SKIP' 'SKIP')
+
+prepare() {
+ cp Makefile ${srcdir}/squashfs${pkgver}/${_origpkgname}/Makefile.tmp
+ cd ${srcdir}/squashfs${pkgver}
+ patch -p0 < ../patch0.txt
+ mv ${srcdir}/squashfs${pkgver}/${_origpkgname}/Makefile.tmp ${srcdir}/squashfs${pkgver}/${_origpkgname}/Makefile
+}
+
+build() {
+ cd ${srcdir}/squashfs${pkgver}/${_origpkgname}
+ INSTALL_DIR="${pkgdir}"/usr/bin CC=gcc-4.9 make -j5
+}
+
+package() {
+ cd ${srcdir}/squashfs${pkgver}/${_origpkgname}
+ # install -Dm755 mksquashfs ${pkgdir}/usr/bin/mksquashfs
+ # install -m755 unsquashfs ${pkgdir}/usr/bin/unsquashfs
+ # make DESTDIR="$pkgdir/" install
+ make INSTALL_DIR="${pkgdir}"/usr/bin install
+}