summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD21
1 files changed, 10 insertions, 11 deletions
diff --git a/PKGBUILD b/PKGBUILD
index a2ad0bf432dc..66ccc56ba975 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,34 +2,33 @@
# Maintainer: Stefan Husmann <stefan-husmann@t-online.de>
pkgname=sawfish-git
-pkgver=1.12.90.8.g93f35ecf
+pkgver=1.13.0.1.g7f8b7bdd
pkgrel=1
pkgdesc='A window manager extensible using a Lisp-based scripting language.'
arch=('i686' 'x86_64')
url='http://sawfish.wikia.com'
license=('GPL')
-depends=('libsm' 'librep-git' 'rep-gtk-git' 'hicolor-icon-theme' 'libxtst' 'gtk2')
+depends=('libsm' 'librep' 'rep-gtk' 'libxtst')
makedepends=('git' 'gettext' 'emacs')
optdepends=('emacs: for using sawfish.el')
provides=('sawfish=1.11')
conflicts=('sawfish')
-source=('git://github.com/SawfishWM/sawfish.git' arch_poweroff_defaults.patch)
+source=('git+https://github.com/SawfishWM/sawfish.git' arch_poweroff_defaults.patch)
options=('!libtool')
sha1sums=('SKIP' '73dbf5f93c0124c11f0254267d662f86be1f2767')
-_gitname=sawfish
pkgver() {
- cd "$_gitname"
+ cd ${pkgname%-git}
git describe --tags|sed 's/-/./g'|cut -c9-
}
prepare() {
- cd "$_gitname"
+ cd ${pkgname%-git}
patch -p1 < "$srcdir"/arch_poweroff_defaults.patch
}
build() {
- cd "$_gitname"
+ cd ${pkgname%-git}
./autogen.sh
./configure --prefix=/usr --with-nls
make
@@ -37,10 +36,10 @@ build() {
}
package() {
- cd "$_gitname"
+ cd ${pkgname%-git}
make DESTDIR="$pkgdir" install
- install -Dm644 sawfish.el $pkgdir/usr/share/emacs/site-lisp/sawfish.el
- install -Dm644 sawfish.elc $pkgdir/usr/share/emacs/site-lisp/sawfish.elc
+ install -Dm644 sawfish.el "$pkgdir"/usr/share/emacs/site-lisp/sawfish.el
+ install -Dm644 sawfish.elc "$pkgdir"/usr/share/emacs/site-lisp/sawfish.elc
install -Dm644 lisp/sawfish/wm/tile/readme.org \
- $pkgdir/usr/share/doc/$pkgname/readme.tiling.org
+ "$pkgdir"/usr/share/doc/$pkgname/readme.tiling.org
}