summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD31
1 files changed, 13 insertions, 18 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 67e365cecfd4..7eb37c62525b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,46 +2,41 @@
# Contributor: Fixed Torres <aur_linuxero@outlook.com>
pkgname=sayonara-player
-_pkgver=1.5.1-stable5
+_pkgver=1.7.0-stable1
pkgver=${_pkgver//-/_}
-pkgrel=2
+pkgrel=1
pkgdesc="Small, clear and fast audio player for Linux written in C++, supported by the Qt framework. It uses Gstreamer as audio backend."
arch=(i686 x86_64)
url="http://sayonara-player.com"
license=(GPL3)
depends=(qt5-base taglib gst-plugins-base gst-plugins-good)
-makedepends=(cmake qt5-tools gst-plugins-bad)
+makedepends=(cmake qt5-tools qt5-svg gst-plugins-bad)
optdepends=('gst-libav: additional codecs'
'gst-plugins-bad: additional codecs'
'gst-plugins-ugly: additional codecs')
-source=("http://sayonara-player.com/sw/${pkgname}-${_pkgver}.tar.gz"
- "sayonara-qpainter.patch::https://gitlab.com/luciocarreras/sayonara-player/-/commit/8ece134217a3efaf61383e060353f105ab1a4b21.patch")
-sha512sums=('0400a768685a65ac1d7379c10fa8ee7146a181fb208507fe40175feee5352e7ac9c263f6b506711aa93ac0aed3f64c1052790830181cec2d354a05c11c886a13'
- 'd7a189bfa925a35d2534ce13b6d2407222203b7241abd8b08f3a4ae1f4f0d6bca9c93bd06b70ee7a2783cd32710ed7a782e8fa9dc06b98b3798149fad2bba170')
+source=("http://sayonara-player.com/sw/${pkgname}-${_pkgver}.tar.gz")
+sha512sums=('b9e09770fb6a4dd2ee9ef2691f844e07cd4ed82467c1a70858538a2af1173308ec45481fc7bc48ba7d0183079befb603a44f352ee7e71073bb16f2e62dcb2177')
prepare() {
- cd "$srcdir/$pkgname"
+ cd "${srcdir}/${pkgname}-${_pkgver}"
[[ -d build ]] || mkdir build
- patch -Np1 -i ../sayonara-qpainter.patch
}
build() {
- cd "$srcdir/${pkgname}/build"
+ cd "${srcdir}/${pkgname}-${_pkgver}/build"
cmake .. \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_BUILD_TYPE=Release \
- -DUSE_SYSTEM_TAGLIB=1
+ -DWITH_TESTS=1
make
-
-# -DWITH_TESTS=1
}
-#check() {
-# cd "$srcdir/${pkgname}/build"
-# make test
-#}
+check() {
+ cd "${srcdir}/${pkgname}-${_pkgver}/build"
+ make test
+}
package() {
- cd "$srcdir/${pkgname}/build"
+ cd "${srcdir}/${pkgname}-${_pkgver}/build"
make DESTDIR="$pkgdir/" install
}