summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rwxr-xr-xPKGBUILD55
1 files changed, 38 insertions, 17 deletions
diff --git a/PKGBUILD b/PKGBUILD
index f7fa656b6b2a..dc4f2319d2e8 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,29 +1,50 @@
+# Maintainer: Fabio 'Lolix' Loli <fabio.loli@disroot.org> -> https://github.com/FabioLolix
# Contributor: Fixed Torres <aur_linuxero@outlook.com>
-# Maintainer: Fixed Torres <aur_linuxero@outlook.com>
pkgname=sayonara-player-git
-pkgver=1.5.1_stable5
+pkgver=1.6.0.beta6.r17.g21020349
pkgrel=1
-pkgdesc="Is a small, clear and fast audio player for Linux written in C++, supported by the Qt framework. It uses Gstreamer as audio backend."
-arch=('i686' 'x86_64')
+pkgdesc="Small, clear and fast audio player for Linux written in C++, supported by the Qt framework. It uses Gstreamer as audio backend."
+arch=(i686 x86_64)
url="http://sayonara-player.com"
-license=('GPL3')
-depends=('qt5-base' 'taglib' 'gst-plugins-base' 'gst-plugins-good' 'gst-plugins-bad' 'libmtp')
-optdepends=('lame' 'gst-plugins-ugly')
-makedepends=('cmake' 'qt5-tools')
-conflicts=('sayonara-player-svn' 'sayonara-player' 'sayonara-bin')
-source=("${pkgname}::git+https://git.sayonara-player.com/sayonara.git")
+license=(GPL3)
+depends=(qt5-base taglib gst-plugins-base gst-plugins-good)
+makedepends=(cmake qt5-tools qt5-svg git gst-plugins-bad)
+optdepends=('gst-libav: additional codecs'
+ 'gst-plugins-bad: additional codecs'
+ 'gst-plugins-ugly: additional codecs')
+provides=(sayonara-player)
+conflicts=(sayonara-player)
+source=("git+https://gitlab.com/luciocarreras/sayonara-player.git")
+sha512sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/${pkgname%-git}"
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+prepare() {
+ cd "$srcdir/${pkgname%-git}"
+ [[ -d build ]] || mkdir build
+}
build() {
- cd "$srcdir/$pkgname"
- mkdir build && cd build
- cmake .. -DCMAKE_INSTALL_PREFIX=/usr -DCMAKE_BUILD_TYPE="Release"
- make
+ cd "$srcdir/${pkgname%-git}/build"
+ cmake .. \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DUSE_SYSTEM_TAGLIB=1 \
+ -DWITH_TESTS=1
+ make
+}
+
+check() {
+ cd "$srcdir/${pkgname%-git}/build"
+ make test
}
package() {
- cd "$srcdir/$pkgname/build"
- make DESTDIR="$pkgdir/" install
+ cd "$srcdir/${pkgname%-git}/build"
+ make DESTDIR="$pkgdir/" install
}
-sha512sums=('SKIP')