summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD56
1 files changed, 56 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b4ee5d38dc9a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,56 @@
+# Maintainer: Muflone http://www.muflone.com/contacts/english/
+# Contributor: György Balló <ballogy@freestart.hu>
+# Contributor: Travis Willard <travisw@wmpub.ca>
+# Contributor: William Rea <sillywilly@gmail.com>
+
+pkgname=sbackup
+pkgver=0.11.6
+pkgrel=2
+pkgdesc="Simple backup solution intended for desktop use"
+arch=('any')
+url="https://launchpad.net/sbackup"
+license=('GPL')
+depends=('python2-gconf' 'python2-libgnome' 'python2-notify' 'gvfs' 'dbus-python' 'hicolor-icon-theme' 'xdg-utils')
+makedepends=('python2-distribute')
+optdepends=('python-pexpect: for ssh fuse plugin'
+ 'sshfs: for ssh plugin'
+ 'curlftpfs: for ftp and sftp fuse plugins')
+install="${pkgname}.install"
+source=("http://launchpad.net/${pkgname}/${pkgver%.*}/${pkgver}/+download/${pkgname}_${pkgver}.tar.gz"
+ "sbackup.conf"
+ "move-sbin-to-bin.patch")
+sha256sums=('a7684837ac2dba199ae0e3a6e6af972b0ef328db0bb79c847e289e4c6418887d'
+ 'd354338c794088c3e7c62162c414394bee339f05535f2316d00bc19c0f1af9b9'
+ 'a0e7302d5053b44e36439d45e954c89689c0f826761c3bae8fdbd67037a54d43')
+
+prepare() {
+ patch -p0 -i "../move-sbin-to-bin.patch"
+}
+
+build() {
+ cd "${pkgname}-${pkgver}"
+ find . -type f | xargs sed -i 's@^#!.*python$@#!/usr/bin/env python2@'
+ sed -i "s/dpkg --get-selections/pacman -Q/" src/sbackup/core/snapshot.py
+
+ make PYTHON=python2 PREFIX=/usr
+}
+
+package() {
+ # Add configuration file to tmpfiles.d
+ install -m755 -d "${pkgdir}/usr/lib/tmpfiles.d"
+ install -m644 -t "${pkgdir}/usr/lib/tmpfiles.d" "sbackup.conf"
+
+ # Install package files
+ cd "${pkgname}-${pkgver}"
+ make PYTHON=python2 \
+ PREFIX=/usr \
+ DESTDIR="${pkgdir}/usr" \
+ sysconf_dir=${pkgdir}/etc \
+ SETUP.PY_OPTS="--root=${pkgdir}/" \
+ DISABLE_MAKEFILE_GTK_UPDATE_ICON_CACHE=1 \
+ DISABLE_MAKEFILE_DESKTOP_DATABASE_RELOAD=1 \
+ DISABLE_MAKEFILE_DBUS_RELOAD=1 \
+ GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1 \
+ DISABLE_MAKEFILE_CLEAN_DATA=1 \
+ install
+}