summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD27
1 files changed, 14 insertions, 13 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 10a909f13855..53d70c886213 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,22 +1,23 @@
-# Maintainer: Jendrik Wenke <jendrikwenke+aur at gmail dot com>
+# Maintainer: Mikael Blomstrand <mbloms ÅT kth DÖT se>
+# Contributor: Jendrik Wenke <jendrikwenke+aur at gmail dot com>
pkgname=scala-dotty
-pkgver=0.12.0
-_pkgverWithHyphen=${pkgver//_/-}
+pkgver=0.17.0
pkgrel=1
-pkgdesc='A platform to try out new language concepts and compiler technologies for Scala'
+pkgdesc='Research compiler that will become Scala 3'
arch=('any')
url='http://dotty.epfl.ch'
license=('BSD')
-depends=('java-environment=8')
-source=("https://github.com/lampepfl/dotty/releases/download/$_pkgverWithHyphen/dotty-$_pkgverWithHyphen.tar.gz")
-sha1sums=('1a62c5459f0294c08a221aa5ebb197ab9bb83978')
+depends=('java-environment>=8' 'java-environment<=11')
+source=("https://github.com/lampepfl/dotty/releases/download/${pkgver}/dotty-${pkgver}.tar.gz")
+sha1sums=('00a5ec1881efb49584164d6b3773543fe2d07350')
+sha256sums=('258f3b49601c6f409bac8c62591fe389b5a4990a88bb25f235d989a944ffa63e')
package() {
- mkdir -p "$pkgdir/usr/bin" "$pkgdir/usr/share/scala-dotty"
- cp -r "$srcdir/dotty-$_pkgverWithHyphen/bin" "$pkgdir/usr/share/scala-dotty"
- cp -r "$srcdir/dotty-$_pkgverWithHyphen/lib" "$pkgdir/usr/share/scala-dotty"
- ln -s "/usr/share/scala-dotty/bin/dotc" "$pkgdir/usr/bin/dotc"
- ln -s "/usr/share/scala-dotty/bin/dotd" "$pkgdir/usr/bin/dotd"
- ln -s "/usr/share/scala-dotty/bin/dotr" "$pkgdir/usr/bin/dotr"
+ install -d "${pkgdir}/usr/bin" "${pkgdir}/usr/share/scala-dotty/bin"
+ cp -r "${srcdir}/dotty-${pkgver}/lib" "${pkgdir}/usr/share/scala-dotty"
+ install -m755 "${srcdir}/dotty-${pkgver}/bin/"* "${pkgdir}/usr/share/scala-dotty/bin"
+ ln -s "../share/scala-dotty/bin/dotc" "${pkgdir}/usr/bin/dotc"
+ ln -s "../share/scala-dotty/bin/dotd" "${pkgdir}/usr/bin/dotd"
+ ln -s "../share/scala-dotty/bin/dotr" "${pkgdir}/usr/bin/dotr"
}