summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD16
1 files changed, 8 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index c80cecbe4f43..80cca9f4cfe5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,20 +1,20 @@
# Maintainer: Vasili Novikov <n1dr+cmarchlinux@yaaandex.com> (replace "aaa" with "a")
+
pkgname=scalafmt-native-bin
-pkgver=2.6.3
+pkgver=2.7.1
pkgrel=1
-pkgdesc='Code formatter for Scala, native version via graalvm'
+pkgdesc='Code formatter for Scala, native version via graalvm, statically compiled with musl'
url='https://scalameta.org/scalafmt/'
-source=("${pkgname}-${pkgver}.zip::https://github.com/scalameta/scalafmt/releases/download/v$pkgver/scalafmt-linux.zip")
+source=("${pkgname}-${pkgver}.musl::https://github.com/scalameta/scalafmt/releases/download/v${pkgver}/scalafmt-linux-musl")
+
license=('Apache-2.0')
-# I'm not actually sure which architectures are supported.
-# Please write if the binary won't work.
-arch=('any')
+arch=('x86_64')
-sha256sums=('c4d42bfddea3a65a3099ba1f9787af5f9995633512750d661d51b737b6ebdf30')
+sha256sums=('6fb4301d5aece59fb11dbc7e8a57551952398ddef1591544d4c4857471d61edf')
package() {
cd "$srcdir"
- install -Dm755 scalafmt "${pkgdir}/usr/bin/scalafmt"
+ install -Dm755 "${pkgname}-${pkgver}.musl" "${pkgdir}/usr/bin/scalafmt"
}