summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD41
1 files changed, 17 insertions, 24 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 50e9407f7d31..e11d4cc39ddc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,43 +1,36 @@
+# Maintainer: Levente Polyak <anthraxx[at]archlinux[dot]org>
# Contributor: Allen Choong <allencch at hotmail dot com>
pkgname=scanmem-git
-_gitname=scanmem
-pkgver=v0.15.2
+pkgver=0.15.2.6.g5cf1f26
pkgrel=1
-pkgdesc="A utility used to locate the address of a variable in an executing process."
+pkgdesc="Memory scanner designed to isolate the address of an arbitrary variable in an executing process"
+url="https://github.com/scanmem/scanmem"
arch=('i686' 'x86_64')
-url="https://github.com/coolwan/scanmem"
+license=('GPL3')
provides=('scanmem')
conflicts=('scanmem')
-license=('GPL3')
-depends=('python' 'pygtk' 'polkit' 'python-gobject')
-makedepends=('intltool')
-#optdepends=('gksu: needed for the GameConqueror GUI.')
-source=("git+https://github.com/scanmem/scanmem.git")
-md5sums=('SKIP')
+depends=('pygtk' 'python-gobject' 'polkit')
+makedepends=('git' 'intltool')
+install=scanmem.install
+source=(${pkgname}::git+https://github.com/scanmem/scanmem.git)
+sha512sums=('SKIP')
pkgver() {
- cd $_gitname
- # Use the tag of the last commit
- git describe --always | sed 's|-|.|g'
+ cd ${pkgname}
+ git describe --always|sed 's|-|.|g'|sed -r 's|v(.*)|\1|'
}
build() {
- cd $_gitname
-
+ cd ${pkgname}
./autogen.sh
./configure --enable-gui --prefix=/usr
- msg2 "Building..."
- make -s
+ make
}
package() {
- cd $_gitname
- make -s DESTDIR="$pkgdir" install
-
- # Replacing calls to the Python 3.x interpreter to the Python 2.x one:
- #sed 's|python|python2|g' -i "$pkgdir/usr/bin/gameconqueror"
- #sed 's|#!/usr/bin/env python|#!/usr/bin/env python2|g' -i \
- # "$pkgdir/usr/share/gameconqueror/"{backend.py,GameConqueror.py,hexview.py}
+ cd ${pkgname}
+ make DESTDIR="${pkgdir}" install
}
+# vim: ts=2 sw=2 et: