summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD13
1 files changed, 10 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index cb9b40e4f590..1e37cf8e6072 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Contributor: Allen Choong <allencch at hotmail dot com>
pkgname=scanmem-git
-pkgver=0.15.2.6.g5cf1f26
+pkgver=0.15.4.20.g063c588
pkgrel=1
pkgdesc="Memory scanner designed to isolate the address of an arbitrary variable in an executing process"
url="https://github.com/scanmem/scanmem"
@@ -13,14 +13,21 @@ conflicts=('scanmem')
depends=('pygtk' 'python-gobject' 'polkit')
makedepends=('git' 'intltool')
install=scanmem.install
-source=(${pkgname}::git+https://github.com/scanmem/scanmem.git)
-sha512sums=('SKIP')
+source=(${pkgname}::git+https://github.com/scanmem/scanmem.git
+ drop-gtk-update-icon.patch)
+sha512sums=('SKIP'
+ '5df78e2dcdaf5c2bf355911f9851375ffeed819dd50bfdc47c5cb8096eaa9b7aa69b7852b937b782661e27d213d8543309dedd92ada38e225fd1375e3f12fe3c')
pkgver() {
cd ${pkgname}
git describe --always|sed 's|-|.|g'|sed -r 's|v(.*)|\1|'
}
+prepare() {
+ cd ${pkgname}
+ patch -Rp1 < "${srcdir}/drop-gtk-update-icon.patch"
+}
+
build() {
cd ${pkgname}
./autogen.sh