summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD7
1 files changed, 3 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 229a66e36e2c..a09fa4f3236e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,8 +2,8 @@
# Contributor: Allen Choong <allencch at hotmail dot com>
pkgname=scanmem-git
-pkgver=0.15.4.751.6a5e2e8
-pkgrel=2
+pkgver=0.15.7.786.1dd1f3d
+pkgrel=1
pkgdesc="Memory scanner designed to isolate the address of an arbitrary variable in an executing process"
url="https://github.com/scanmem/scanmem"
arch=('i686' 'x86_64')
@@ -12,13 +12,12 @@ provides=('scanmem')
conflicts=('scanmem')
depends=('gtk3' 'python-gobject' 'polkit')
makedepends=('git' 'intltool')
-install=scanmem.install
source=(${pkgname}::git+https://github.com/scanmem/scanmem.git)
sha512sums=('SKIP')
pkgver() {
cd ${pkgname}
- printf "%s.%s.%s" "$(git describe --tags --abbrev=0|sed -r 's|-|.|g'|sed -r 's|v?(.*)|\1|')" \
+ printf "%s.%s.%s" "$(git tag|sort|tail -n1|sed -r 's|-|.|g'|sed -r 's|v?(.*)|\1|')" \
"$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}