summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD16
1 files changed, 5 insertions, 11 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 1e37cf8e6072..cfe320d34b5d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Contributor: Allen Choong <allencch at hotmail dot com>
pkgname=scanmem-git
-pkgver=0.15.4.20.g063c588
+pkgver=0.15.4.751.6a5e2e8
pkgrel=1
pkgdesc="Memory scanner designed to isolate the address of an arbitrary variable in an executing process"
url="https://github.com/scanmem/scanmem"
@@ -13,19 +13,13 @@ conflicts=('scanmem')
depends=('pygtk' 'python-gobject' 'polkit')
makedepends=('git' 'intltool')
install=scanmem.install
-source=(${pkgname}::git+https://github.com/scanmem/scanmem.git
- drop-gtk-update-icon.patch)
-sha512sums=('SKIP'
- '5df78e2dcdaf5c2bf355911f9851375ffeed819dd50bfdc47c5cb8096eaa9b7aa69b7852b937b782661e27d213d8543309dedd92ada38e225fd1375e3f12fe3c')
+source=(${pkgname}::git+https://github.com/scanmem/scanmem.git)
+sha512sums=('SKIP')
pkgver() {
cd ${pkgname}
- git describe --always|sed 's|-|.|g'|sed -r 's|v(.*)|\1|'
-}
-
-prepare() {
- cd ${pkgname}
- patch -Rp1 < "${srcdir}/drop-gtk-update-icon.patch"
+ printf "%s.%s.%s" "$(git describe --tags --abbrev=0|sed -r 's|-|.|g'|sed -r 's|v?(.*)|\1|')" \
+ "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
build() {