summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD11
1 files changed, 8 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index f73e9eabb73d..b0eb9a298440 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# Maintainer: Philipp A. <flying-sheep@web.de>
pkgname=scanpy
-pkgver=1.9.1
-pkgrel=2
+pkgver=1.9.3
+pkgrel=1
pkgdesc='Single-Cell Analysis in Python'
arch=(any)
provides=(scanpy python-scanpy)
@@ -29,6 +29,7 @@ depends=(
python-sinfo
)
optdepends=(
+ 'python-igraph: PAGA support (also transitively needed for Louvain/Leiden)'
'python-louvain-igraph: Louvain clustering'
'python-leidenalg: leiden community detection'
'python-bbknn: Batch balanced KNN (batch correction)'
@@ -38,10 +39,14 @@ optdepends=(
'python-harmonypy: Harmony dataset integration algorithm'
'python-scanorama: Scanorama dataset integration algorithm'
'python-scrublet: Cell doublet detection'
+ 'rapids-cudf: NVIDIA RAPIDS acceleration'
+ 'rapids-cuml: NVIDIA RAPIDS acceleration'
+ 'rapids-cugraph: NVIDIA RAPIDS acceleration'
+ 'python-dask: Dask parallelization'
)
makedepends=(python-flit-core python-setuptools-scm python-build python-installer python-wheel)
source=("https://files.pythonhosted.org/packages/source/${pkgname::1}/$pkgname/$pkgname-$pkgver.tar.gz")
-sha256sums=('00c9a83b649da7e0171c91e9a08cff632102faa760614fd05cd4d1dbba4eb541')
+sha256sums=('dfe65f9acd9f4c1740079a099f89fa6a44b6f0ef75ecaf85247ad4af859144d7')
build() {
cd "$pkgname-$pkgver"