summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD9
1 files changed, 4 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 1522f7035b19..d528acb44b86 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Tobias Bachmann <tobachmann@gmx.de>
pkgname=scantools
-pkgver=0.6.4
-pkgrel=3
+pkgver=1.0.0
+pkgrel=1
pkgdesc="scantools is a library and a matching set of command line applications for graphics manipulation, written with a view towards the handling of scanned documents and generation of high-quality PDF files."
arch=('x86_64')
url="https://cplx.vm.uni-freiburg.de/scantools/"
@@ -9,14 +9,13 @@ license=('GPL')
depends=('qpdf' 'qt5-imageformats' 'gcc' 'graphviz' 'jbig2dec' 'libjpeg-turbo' 'libtiff' 'openjpeg2' 'tesseract' 'qpdf' 'qt5-base' 'zlib')
makedepends=('cmake' 'doxygen' 'git')
source=("https://gitlab.com/kebekus/scantools/-/archive/${pkgver}/${pkgname}-${pkgver}.tar.gz")
-sha256sums=('154b9c4da5f4d08bdaac5bf740f07fcb20e19028fd0c429d85636cbba7ed4071')
+sha256sums=('359d18bf4a35031532e0a7173c291943e63811244105e8bb1c58baebbffe8473')
build() {
cd ${pkgname}-${pkgver}
- echo "WARN_AS_ERROR = NO" >> src/libscantools/Doxyfile.in # Workaround for Doxygen error
mkdir build
cd build
- cmake -DCMAKE_BUILD_TYPE=release -DCMAKE_INSTALL_PREFIX=/usr -DCMAKE_INSTALL_LIBDIR=/usr/lib ../src
+ cmake -DCMAKE_BUILD_TYPE=release -DCMAKE_INSTALL_PREFIX=/usr -DCMAKE_INSTALL_LIBDIR=/usr/lib ..
make -j $(nproc)
}