summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD13
1 files changed, 7 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index bee1f26d32f3..1522f7035b19 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Tobias Bachmann <tobachmann@gmx.de>
pkgname=scantools
pkgver=0.6.4
-pkgrel=2
+pkgrel=3
pkgdesc="scantools is a library and a matching set of command line applications for graphics manipulation, written with a view towards the handling of scanned documents and generation of high-quality PDF files."
arch=('x86_64')
url="https://cplx.vm.uni-freiburg.de/scantools/"
@@ -12,11 +12,12 @@ source=("https://gitlab.com/kebekus/scantools/-/archive/${pkgver}/${pkgname}-${p
sha256sums=('154b9c4da5f4d08bdaac5bf740f07fcb20e19028fd0c429d85636cbba7ed4071')
build() {
- cd ${pkgname}-${pkgver}
- mkdir build
- cd build
- cmake -DCMAKE_BUILD_TYPE=release -DCMAKE_INSTALL_PREFIX=/usr -DCMAKE_INSTALL_LIBDIR=/usr/lib ../src
- make -j $(nproc)
+ cd ${pkgname}-${pkgver}
+ echo "WARN_AS_ERROR = NO" >> src/libscantools/Doxyfile.in # Workaround for Doxygen error
+ mkdir build
+ cd build
+ cmake -DCMAKE_BUILD_TYPE=release -DCMAKE_INSTALL_PREFIX=/usr -DCMAKE_INSTALL_LIBDIR=/usr/lib ../src
+ make -j $(nproc)
}
package() {