summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD25
1 files changed, 25 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..26822f3d73c3
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Tobias Bachmann <tobachmann@gmx.de>
+pkgname=scantools
+pkgver=0.6.4
+pkgrel=1
+pkgdesc="scantools is a library and a matching set of command line applications for graphics manipulation, written with a view towards the handling of scanned documents and generation of high-quality PDF files."
+arch=('x86_64')
+url="https://cplx.vm.uni-freiburg.de/scantools/"
+license=('GPL')
+depends=('qt5-imageformats')
+makedepends=('cmake' 'doxygen' 'gcc' 'git' 'graphviz' 'jbig2dec' 'libjpeg-turbo' 'libtiff' 'openjpeg2' 'tesseract' 'qpdf' 'qt5-base' 'zlib')
+source=("https://gitlab.com/kebekus/scantools/-/archive/${pkgver}/${pkgname}-${pkgver}.tar.gz")
+sha256sums=('154b9c4da5f4d08bdaac5bf740f07fcb20e19028fd0c429d85636cbba7ed4071')
+
+build() {
+ cd ${pkgname}-${pkgver}
+ mkdir build
+ cd build
+ cmake -DCMAKE_BUILD_TYPE=release -DCMAKE_INSTALL_PREFIX=/usr -DCMAKE_INSTALL_LIBDIR=/usr/lib ../src
+ make -j $(nproc)
+}
+
+package() {
+ cd ${pkgname}-${pkgver}/build
+ make DESTDIR="${pkgdir}/" install
+}