summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 8 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 52602262ccf8..1587b213b26a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,17 +3,23 @@
pkgname=schismtracker
pkgver=20180513
-pkgrel=1
+pkgrel=2
pkgdesc='A reimplementation of the Impulse Tracker music editor.'
arch=('i686' 'x86_64' 'armv7h') # and probably other ARMs
url='http://schismtracker.org/'
license=('GPL')
depends=('sdl' 'gcc-libs' 'libxv')
-makedepends=('git')
+makedepends=('git' 'python')
conflicts=('schismtracker-git')
source=("$pkgname::git+https://github.com/schismtracker/schismtracker.git#tag=$pkgver")
md5sums=('SKIP')
+prepare () {
+ # Correcting the file "schism.desktop"
+ cd $srcdir/$pkgname/sys/fd.org
+ sed -i 's/Audio;/AudioVideo;Audio;/' schism.desktop
+}
+
build() {
cd $pkgname
autoreconf -i