summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD16
1 files changed, 8 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 61e102b489f5..c08ed3b727ec 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,27 +9,27 @@
_pkgname=scidavis
pkgname=scidavis-qt5
-pkgver=1.26
-_commit=1.26
-pkgrel=3
+pkgver=2.0.10
+_commit=2.0.10
+pkgrel=1
pkgdesc="Application for Scientific Data Analysis and Visualization, fork of QtiPlot. Qt5 port"
arch=('x86_64')
url="http://scidavis.sourceforge.net/"
license=('GPL')
-makedepends=('boost' 'cmake' 'qt5-tools' 'sip' 'python-sip')
+makedepends=('boost' 'cmake' 'qt5-tools' 'classdesc>=3.37')
depends=('gsl' 'glu' 'mesa' 'muparser' 'shared-mime-info'
'desktop-file-utils' 'hicolor-icon-theme'
'qwt5-qt5' 'qwtplot3d-qt5'
'python-pyqt5')
conflicts=('scidavis')
source=("${_pkgname}-${pkgver}.zip::https://github.com/highperformancecoder/scidavis/archive/${_commit}.zip"
-'sip_error.patch')
-sha512sums=('c4ccd9ace46eeef5a184ea93bb48b338d6ae50cb06db33a95420370da3e5b9ff3b268e4f9da6d60c9b0c64dcc300cb46b4b9275736869cad039f74f4eee68211'
- '8a57006842e416751d5f6ca6128ecdbba632e88c57f4b2dcb1558626f815c0682eff771697a068f5cbc583f588c6a41eab7bdc3c82f294cbafed1ce1cb04368e')
+'patch-2.0.10')
+sha512sums=('b2f9c86c079ac72585f95ae1ced93b9e6be9e8fd0e84a43106b1a4f1138335d1f04424131fb8bf58585d4645b76e3b919da2221ec039385ad6a0ccce56c02db1'
+ 'f9ae2f099cdead27f73222a5e6d72217e36d10fcd1f4edb6f23f9844b1a962d25ec873d1d676165ad4e45a550d0b65511246f4302c70a28ac2d3d12760df9eb4')
prepare() {
cd "${_pkgname}-${_commit}"
- patch --forward --strip=1 --input="${srcdir}/sip_error.patch"
+ patch --forward --strip=1 --input="${srcdir}/patch-2.0.10"
}
build() {