summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD113
1 files changed, 63 insertions, 50 deletions
diff --git a/PKGBUILD b/PKGBUILD
index f7fb3f459261..4b7af3faa38a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,68 +1,77 @@
-# Maintainer: eolianoe <eolianoe [at] gmail [DoT] com>
-# Contributor: Victor Dmitriyev <mrvvitek@gmail.com>
+#!/hint/bash
+# Maintainer : eolianoe <eolianoe [at] gmail [DoT] com>
+# Contributor : Victor Dmitriyev <mrvvitek@gmail.com>
+# Contributor : bartus <scilab-aur@bartus.33mail.com>
_pkgname=scilab
-pkgname=scilab-git
-pkgver=6.0.0.r101.gac588401314
+_fragment="${FRAGMENT:-#branch=master}"
+_ver_pop_commit="2797926fe5a3af91029ce4fc018ced0c286e6fe3"
+pkgname=${_pkgname}-git
+pkgver=6.2.0.r216.g81a9cc04933
pkgrel=1
-pkgdesc='A scientific software package for numerical computations'
+pkgdesc='A scientific software package for numerical computations.'
arch=('i686' 'x86_64')
-url="https://www.scilab.org/"
-license=('custom:CeCILL' 'BSD')
-depends=('suitesparse>=4.4.1' 'arpack' 'fftw' 'eigen'
- 'hdf5'
- 'libmatio' 'tk' 'curl'
+url='https://www.scilab.org'
+license=('BSD' 'custom:CeCILL' 'GPL2')
+depends=('suitesparse>=4.4.1' 'arpack' 'fftw' 'eigen'
+ 'hdf5' 'libmatio'
+ 'tk' 'bwidget'
+ 'curl' 'inetutils'
'java-runtime>=8'
- 'apache-lucene>=6'
'beanshell' 'eclipse-ecj' 'java-flexdock>=1.2.4' 'fop-hyph'
- 'jeuclid-core' 'jgraphx>=2.0.0.1' 'javahelp2'
+ 'jeuclid-core' 'jgraphx-jre8' 'javahelp2'
'saxon-he' 'jlatexmath-fop>=1.0.3' 'jrosetta>=1.0.4' 'jgoodies-looks' 'java-qdox'
- 'java-skinlf' 'java-testng' 'xalan-java' 'docbook-xsl'
- 'jogl>=2.3.2' 'java-batik>=1.8')
-makedepends=('apache-ant' 'git' 'ocaml' 'java-environment>=8' 'gcc-fortran')
+ 'java-skinlf' 'xalan-java' 'docbook-xsl'
+ 'jogl>=2.3.2' 'apache-lucene>=7'
+ 'java-batik>=1.8' 'java-xmlgraphics-commons>=2.0.1')
+makedepends=('java-environment=8' 'ant>=1.9.0'
+ 'ocaml-findlib' 'ocaml-num' 'gcc-fortran'
+ 'time' 'git')
provides=('scilab')
conflicts=('scilab')
-source=("git://git.scilab.org/scilab"
- "${_pkgname}-jogl-2.3.2.patch"
- "${_pkgname}-LD_LIBRARY_PATH.patch"
+source=("git://git.scilab.org/scilab${_fragment}"
+ "jogl-2.3.2.patch::http://gitweb.scilab.org/?p=scilab.git;a=patch;h=0c977dd8e334bf393e61f81f5fd19c48efc538c9"
+ "ocaml-4.02.patch::http://gitweb.scilab.org/?p=scilab.git;a=patch;h=eb6b830cc812498a451f9d9b497b18bd4785eed5"
"${_pkgname}-strict-jar.patch"
- "${_pkgname}-lucene-6.patch"
- "${_pkgname}-hdf5-type.patch"
- "${_pkgname}-hdf5-1.8.10.patch"
- "${_pkgname}-type.patch")
-
+ "${_pkgname}-LD_LIBRARY_PATH.patch"
+ "${_pkgname}-num.patch"
+ "libxml.patch"
+ "hdf5_18_api.patch"
+ )
sha256sums=('SKIP'
- 'f19f173e989f72bd55bda35e271b3c180ecef4e29da964df3f230fce8b1330fc'
- '37f649fea0196b255e5a8576dd1e8c5fd219c6e8c600b703b35303fb90b6a7e0'
+ '2348c8badad19974174eac99d18f4583c838dd406265d686fa46b6c8c4d04cce'
+ '2aec92a3a12e7c776856edcacbce5115cac784f4a946151d96bcf46d64f10e40'
'38aa094951338fa1d267dc6f397552e175213b0f8ba7b35727c178607861f6dd'
- 'ba7969fff7f839562120534222fbb6421e204f6a382654d80bbab19e0c7a2c66'
- 'c992a4f230dac60c3e217efee04b678c58d856f2aafa6173f742d4c5b050ab9d'
- '2dee1346c240d09ce7870bbbeb3318e0ac5d78f249d855df313e9cb7a2ef7fc0'
- '93597034c6866c3a4aaa7ef92b4588d2753383545ed3366be6cdb404edf949bd')
+ 'a39277cb8cfc3d7929c73ce6d707dc24e3df4b8d8f2d587f075efebda79ff4db'
+ '79c5f32bc2142f9861491787e8ee86d0b75f148141b176bae394ea360b8944d7'
+ 'c04114c4ef63d76bf898808e90c892de093fcc400a2371c7aa287b76c0c5d041'
+ 'f781c2919a0c14be5deed3a8b8866addd8de1171a06aacb96ef1e19535d0988e')
pkgver() {
cd "${srcdir}/${_pkgname}/${_pkgname}"
-
- git describe --long --tags --always | sed -r 's/([^-]*-g)/r\1/;s/-/./g'
+# Tags are dragging behind
+# git describe --long --tags --always | sed -r 's/([^-]*-g)/r\1/;s/-/./g'
+ scilab_ver=$(printf "%d.%d.%d" $(grep -Po '^SCILAB_VERSION_(MAJOR|MINOR|MAINTENANCE)=\K.*' configure.ac))
+ printf "%s.r%s.g%s" "$scilab_ver" "$(git rev-list --count $_ver_pop_commit..HEAD)" "$(git rev-parse --short HEAD)"
}
prepare(){
cd "${srcdir}/${_pkgname}/${_pkgname}"
- # http://bugzilla.scilab.org/show_bug.cgi?id=14539
- patch -p1 < "${srcdir}"/${_pkgname}-hdf5-1.8.10.patch
# https://codereview.scilab.org/#/c/17530/
- patch -p2 < "${srcdir}"/${_pkgname}-jogl-2.3.2.patch
- # Linked to: https://codereview.scilab.org/#/c/18089/
- patch < "${srcdir}"/${_pkgname}-strict-jar.patch
- # Fix to build with lucene >= 6
- patch -p0 < "${srcdir}"/${_pkgname}-lucene-6.patch
- # Fix hdf5 type
- patch -p0 < "${srcdir}"/${_pkgname}-hdf5-type.patch
- # Fix for LD_LIBRARY_PATH
- patch bin/scilab "${srcdir}"/${_pkgname}-LD_LIBRARY_PATH.patch
- # Fix type
- patch -p0 < "${srcdir}"/${_pkgname}-type.patch
+ patch -p2 < "${srcdir}"/jogl-2.3.2.patch
+ # https://codereview.scilab.org/#/c/20161/
+ patch -p2 < "${srcdir}"/ocaml-4.02.patch
+ # https://codereview.scilab.org/#/c/18089/
+ patch -p0 < "${srcdir}"/${_pkgname}-strict-jar.patch
+ # Fix path, to avoid the following error:
+ # An error has been detected while loading /usr/share/scilab//modules/functions/.libs/libscifunctions.so: /usr/share/scilab//modules/functions/.libs/libscifunctions.so: cannot open shared object file: No such file or directory
+ patch -p0 < "${srcdir}"/${_pkgname}-LD_LIBRARY_PATH.patch
+ patch -p0 < "${srcdir}"/${_pkgname}-num.patch
+ # libxml
+ patch -p1 < "${srcdir}"/libxml.patch
+ # hdf5_18_api
+ patch -p1 < "${srcdir}"/hdf5_18_api.patch
}
build() {
@@ -81,21 +90,25 @@ build() {
--with-install-help-xml \
--enable-build-help \
--enable-build-localization \
- --disable-static-system-lib
+ --disable-static-system-lib \
+ --enable-silent-rules \
+ --with-jdk=/usr/lib/jvm/java-8-openjdk/ \
+ FFLAGS="-fallow-argument-mismatch" \
+ CFLAGS="$CFLAGS -fcommon" \
+ CXXFLAGS="$CXXFLAGS -fcommon" \
make
- make doc
+ ((TRAVIS)) || make doc
}
package() {
cd "${srcdir}/${_pkgname}/${_pkgname}"
make DESTDIR="${pkgdir}" install
+ ((TRAVIS)) || make DESTDIR="${pkgdir}" install-data install-html
- install -Dm644 "${srcdir}/${_pkgname}/${_pkgname}/COPYING" \
- "${pkgdir}/usr/share/licenses/${pkgname}/COPYING"
- install -Dm644 "${srcdir}/${_pkgname}/${_pkgname}/COPYING-BSD" \
- "${pkgdir}/usr/share/licenses/${pkgname}/COPYING-BSD"
+ install -Dm644 COPYING "${pkgdir}/usr/share/licenses/${pkgname}/COPYING"
+ install -Dm644 COPYING-BSD "${pkgdir}/usr/share/licenses/${pkgname}/COPYING-BSD"
}
# vim:set ts=2 sw=2 et: