summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD32
1 files changed, 32 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1eb75ca54050
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# $Id: PKGBUILD 266875 2017-11-15 14:29:11Z foutrelis $
+# Maintainer: Alexander F Rødseth <xyproto@archlinux.org>
+# Contributor: Thomas S Hatch <thatch45@gmail.com>
+# Contributor: Corrado 'bardo' Primier <corrado.primier@mail.polimi.it>
+# Contributor: Jochem Kossen <j.kossen@home.nl>
+# Contributor: Daniel J Griffiths <ghost1227@archlinux.us>
+
+pkgname=scite
+pkgver=4.0.2
+pkgrel=1
+pkgdesc='Editor with facilities for building and running programs'
+arch=('x86_64')
+url='http://www.scintilla.org/SciTE.html'
+license=('custom:scite')
+depends=('gtk3')
+backup=('usr/share/scite/SciTEGlobal.properties')
+source=("http://downloads.sourceforge.net/sourceforge/scintilla/${pkgname}${pkgver//./}.tgz")
+sha256sums=('1f9bb8eccbaed77c110c30c0e6dbaac04b3f62b751a930192b133a7b6f0f29fb')
+
+build() {
+ GTK3=1 make -C "scintilla/gtk"
+ GTK3=1 make -C "$pkgname/gtk"
+}
+
+package() {
+ GTK3=1 make -C "$pkgname/gtk" DESTDIR="$pkgdir" install
+ install -Dm644 "$pkgname/License.txt" \
+ "$pkgdir/usr/share/licenses/$pkgname/LICENSE-scite"
+ install -Dm644 "scintilla/License.txt" \
+ "$pkgdir/usr/share/licenses/$pkgname/LICENSE-scintilla"
+ ln -sf "/usr/bin/SciTE" "$pkgdir/usr/bin/scite"
+}