summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD6
1 files changed, 3 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 94ef1889db74..a90ecff32324 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,19 +2,19 @@
# Contributor: Onur Kader <onurorkunkader1999@gmail.com>
pkgname=scnlib
-pkgver=1.1.2
+pkgver=1.1.3
pkgrel=1
pkgdesc="A formatted input library, think {fmt} but in the other direction. 'scanf' for modern C++"
arch=("x86_64")
url="https://github.com/eliaskosunen/scnlib"
license=("Apache")
-makedepends=("git" "cmake" "doxygen" "python-sphinx" "python-breathe" "doctest" "benchmark")
+makedepends=("git" "cmake" "doxygen" "python-sphinx" "python-sphinx_rtd_theme" "python-breathe" "doctest" "benchmark")
source=("${pkgname}::git+https://github.com/eliaskosunen/scnlib.git#tag=v${pkgver}")
md5sums=('SKIP')
build() {
cmake -B build -S "$pkgname" \
- -DCMAKE_BUILD_TYPE=None \
+ -DCMAKE_BUILD_TYPE=Release \
-DCMAKE_INSTALL_PREFIX="/usr" \
-DCMAKE_INTERPROCEDURAL_OPTIMIZATION=ON \
-DBUILD_SHARED_LIBS=ON