summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD20
1 files changed, 18 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 094fc4c1a1a7..8fba39754524 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=scorep
pkgver=8.3
-pkgrel=2
+pkgrel=3
pkgdesc="Highly scalable and easy-to-use tool suite for profiling, event tracing, and online analysis of HPC applications."
arch=('i686' 'x86_64')
url="http://www.vi-hps.org/projects/score-p/"
@@ -15,12 +15,28 @@ sha256sums=('76c914e6319221c059234597a3bc53da788ed679179ac99c147284dcefb1574a')
build() {
cd "${srcdir}/${pkgname}-${pkgver}"
- ./configure --prefix=/usr --with-mpi=openmpi --with-shmem=no --enable-shared
+
+ local _configure_flags=(
+ --prefix=/usr
+ --with-mpi=openmpi
+ --with-shmem=openmpi
+ --enable-shared
+ )
+ ./configure "${_configure_flags[@]}"
+
make
}
+check() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+
+ # -j1 for some Fortran module dependency issue
+ make -j1 --keep-going check |& tee -a make_check.log || true
+}
+
package() {
cd "${srcdir}/${pkgname}-${pkgver}"
+
make DESTDIR="${pkgdir}/" install
install -Dm644 COPYING "${pkgdir}/usr/share/licenses/${pkgname}/COPYING"
}