summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD14
1 files changed, 4 insertions, 10 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 3889c229d132..061e21448a29 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=screencloud
pkgver=1.3.1
-pkgrel=1
+pkgrel=2
pkgdesc='An easy to use screenshot sharing application'
arch=('i686' 'x86_64')
url='https://github.com/olav-st/screencloud/'
@@ -11,12 +11,12 @@ license=('GPL2')
makedepends=('cmake')
depends=(
# official repositories:
- 'quazip' 'zlib' 'python' 'openssl' 'libx11' 'libxext' 'qt5-base'
+ 'quazip' 'zlib' 'python2' 'openssl' 'libx11' 'libxext' 'qt5-base'
'qt5-svg' 'qt5-x11extras' 'qt5-multimedia' 'hicolor-icon-theme'
# AUR:
'pythonqt'
)
-optdepends=('python-crypto: for SFTP support')
+optdepends=('python2-crypto: for SFTP support')
conflicts=('screencloud-git')
source=("${pkgname}-${pkgver}.tar.gz"::"https://github.com/olav-st/${pkgname}/archive/v${pkgver}.tar.gz"
'screencloud-1.3.1-fix-pythonqt-detection.patch')
@@ -32,18 +32,12 @@ prepare() {
}
build() {
- # needed for the self-compiled version
- local _consumer_key='ef5d77317892721a0acebbbc8157272b055da8074'
- local _consumer_secret='2d745141473f640b566aba29147fd672'
-
cd "${pkgname}-${pkgver}/build"
cmake \
-DCMAKE_INSTALL_PREFIX:PATH='/usr' \
-DCOLOR_OUTPUT:BOOL='ON' \
- -DCONSUMER_KEY_SCREENCLOUD:STRING="$_consumer_key" \
- -DCONSUMER_SECRET_SCREENCLOUD:STRING="$_consumer_secret" \
- -DPYTHON_USE_PYTHON3:BOOL='ON' \
+ -DPYTHON_USE_PYTHON3:BOOL='OFF' \
-DQT_USE_QT5:BOOL='ON' \
-Wno-dev \
..