summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD28
1 files changed, 14 insertions, 14 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 35595dede3a7..53a7c5e701fc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,29 +1,29 @@
# Maintainer: Sefa Eyeoglu <contact@scrumplex.net>
pkgname=screenshot-bash
-pkgver=3.0.0
+pkgver=4.0.0
pkgrel=1
pkgdesc="Screenshot script, that uploads screenshot to a predefined server."
arch=("any")
-url="https://gitlab.com/Scrumplex/ScreenshotBASH"
+url="https://gitlab.com/Scrumplex/screenshot-bash"
license=("GPL3")
-depends=("bash" "kdialog" "sox")
+depends=("bash" "coreutils" "curl" "file" "gzip" "kdialog" "sox" "xdg-utils")
optdepends=("spectacle: use default screenshot program"
- "flameshot: use alternative screenshot program")
-provides=("screenshot-bash" "upload-bash")
-conflicts=("screenshot-bash-git")
-
-source=("https://gitlab.com/Scrumplex/ScreenshotBASH/-/archive/${pkgver}/ScreenshotBASH-${pkgver}.tar.gz")
-sha512sums=('5b247b60742ac8add8ff37ae5d721ed19d2cf668a7ef718caf3308089982027c549d28e26108ae05c24f18e677869536ca2ca7e40b7e2863aaa806ca1d68a5c0')
+ "flameshot: use alternative screenshot program"
+ "wl-clipboard: use default clipboard tool"
+ "xsel: use alternative clipboard tool")
+provides=("upload-bash")
+source=("https://gitlab.com/Scrumplex/screenshot-bash/-/archive/${pkgver}/screenshot-bash-${pkgver}.tar.gz")
+sha512sums=('e9a5579b189b44e1b61a4c5025db26f909507aea8a15c7e3291e613ac2c6818fc7ca29e1c5f0738c8d80a7d7ee73a463d457f60afbe8829addc868e7db1276b9')
package() {
- cd "ScreenshotBASH-${pkgver}"
+ cd "screenshot-bash-${pkgver}"
- install -Dm755 "screenshotBASH" "$pkgdir/usr/bin/screenshotBASH"
- install -Dm755 "uploadBASH" "$pkgdir/usr/bin/uploadBASH"
+ install -Dm755 "screenshot-bash" "$pkgdir/usr/bin/screenshot-bash"
+ install -Dm755 "upload-bash" "$pkgdir/usr/bin/upload-bash"
- install -Dm644 "screenshotBASH.conf" "$pkgdir/usr/share/doc/${pkgname}/screenshotBASH.conf"
- install -Dm644 "ScreenshotBASH.khotkeys" "$pkgdir/usr/share/khotkeys/ScreenshotBASH.khotkeys"
+ install -Dm644 "screenshot-bash.conf" "$pkgdir/usr/share/doc/${pkgname}/screenshot-bash.conf"
+ install -Dm644 "screenshot-bash.khotkeys" "$pkgdir/usr/share/khotkeys/Screenshot-bash.khotkeys"
}