summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD15
1 files changed, 8 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 0a864de59f34..a2e950ca22b2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,9 @@
# Maintainer: Jake <ja.ke@posteo.de>
pkgname=script-communicator
-_fullname=ScriptCommunicator_04_09_source
-pkgver=4.09
+pkgver=4.10
+_pkgver=04_10
pkgrel=1
+_name=ScriptCommunicator_04_10_source
pkgdesc="Scriptable terminal with Serial/TCP/UDP/SPI/CAN support"
arch=('i686' 'x86_64')
url="http://sourceforge.net/projects/scriptcommunicator/"
@@ -10,22 +11,22 @@ license=('GPL3')
depends=('qt5-script' 'qt5-serialport')
makedepends=('qt5-tools' 'dos2unix' 'icoutils')
-source=("http://sourceforge.net/projects/scriptcommunicator/files/Source/${_fullname}.zip"
+source=("http://sourceforge.net/projects/scriptcommunicator/files/Source/ScriptCommunicator_${_pkgver}_source.zip"
"qmake.patch"
"$pkgname.desktop")
-md5sums=('3b0c0a494c3ab6040250a8cc71f3eba3'
+md5sums=('bf25c7fe3bc4864ae33fd5627c4677e4'
'efe580480b123884895d7aadad495921'
'2178766b1e5dcccffe29d666625d111a')
prepare() {
- cd "${_fullname}"
+ cd "ScriptCommunicatorSetup_${_pkgver}_source"
dos2unix ScriptCommunicator.pro
patch -i "$srcdir/qmake.patch"
}
build() {
- cd "${_fullname}"
+ cd "ScriptCommunicatorSetup_${_pkgver}_source"
qmake -o Makefile ScriptCommunicator.pro
make
}
@@ -33,7 +34,7 @@ build() {
package() {
install -Dm644 "$pkgname.desktop" "$pkgdir/usr/share/applications/$pkgname.desktop"
- cd "${_fullname}"
+ cd "ScriptCommunicatorSetup_${_pkgver}_source"
icotool -x images/main.ico -i 1 -o images/main.png
install -Dm644 "images/main.png" "$pkgdir/usr/share/pixmaps/$pkgname.png"