summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD2
1 files changed, 2 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 55c408ffc198..300ca06f8ed5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -55,6 +55,8 @@ prepare() {
build() {
cd "$srcdir/${pkgname}"
+ sed -i -e 's@sizeof(byte)@sizeof(CryptoPP::byte)@g' md5_hasher.hh
+ sed -i -e 's@reinterpret_cast<const byte@reinterpret_cast<const CryptoPP::byte@g' md5_hasher.hh
sed -i -e 's@#!/usr/bin/python$@#!/usr/bin/python2@' scylla-housekeeping
sed -i -e 's@#!/usr/bin/python$@#!/usr/bin/python2@' seastar/scripts/dpdk_nic_bind.py
sed -i -e 's@#!/usr/bin/python$@#!/usr/bin/python2@' dist/common/scripts/scylla_config_get.py