summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD25
1 files changed, 25 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1dc6a4f6dada
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Emil Lundberg <emil@emlun.se>
+
+pkgname=sddm-theme-abstractdark-git
+pkgver=1.0.0
+pkgrel=1
+pkgdesc="Abstract Dark theme for SDDM by 3ximus"
+arch=('any')
+url="https://github.com/3ximus/abstractdark-sddm-theme"
+license=('CCPL:cc-by-sa')
+depends=('sddm')
+_theme_name='abstractdark'
+_repo_name='abstractdark-sddm-theme'
+source=("git+https://github.com/3ximus/abstractdark-sddm-theme.git")
+md5sums=('SKIP')
+
+pkgver() {
+ echo "$(git -C "${srcdir}/${_repo_name}" rev-list --count HEAD).0.0"
+}
+
+package() {
+ install -d "${pkgdir}"/usr/share/sddm/themes/"${_theme_name}"
+ cp -r "${srcdir}/${_repo_name}"/* "${pkgdir}"/usr/share/sddm/themes/"${_theme_name}"/
+ find "${pkgdir}"/usr/share/sddm/themes/"${_theme_name}" -type d -exec chmod 555 {} \;
+ find "${pkgdir}"/usr/share/sddm/themes/"${_theme_name}" -type f -exec chmod 444 {} \;
+}