summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rwxr-xr-xPKGBUILD10
1 files changed, 8 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 3f39f19ea92e..97aa169755d9 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -22,8 +22,14 @@ sha512sums=('SKIP')
validpgpkeys=('SKIP') # Sam Lantinga
pkgver() {
- cd SDL
- echo $(hg parents --template '{word(-1,latesttag,":")}').$(hg identify -n)
+
+#thanks Kozeid
+
+ cd "SDL"
+ printf "%s.r%s.%s" \
+ "$(hg log -r . -T "{latesttag}" | sed 's/^release-//')" \
+ "$(hg identify -n)" \
+ "$(hg identify -i)"
}
prepare() {