summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD32
1 files changed, 19 insertions, 13 deletions
diff --git a/PKGBUILD b/PKGBUILD
index ea43d221c266..ee5f6cf24c78 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,28 +1,34 @@
-# Maintainer: Steffen Weber <-boenki-gmx-de->
+# Maintainer: Guoyi Zhang <myname at malacology dot net>
+# Contributor: Steffen Weber <-boenki-gmx-de->
# Contributor: Nick B <Shirakawasuna at gmail _dot_com>
pkgname=seaview
pkgver=5.0.5
-pkgrel=6
+pkgrel=8
pkgdesc="GUI for multiple sequence alignment and molecular phylogeny. https://doi.org/10.1093/molbev/msp259"
arch=('x86_64')
url="http://doua.prabi.fr/software/seaview"
license=('GPL3')
+depends=('fltk')
+makedepends=('make' 'gcc' 'fltk')
optdepends=('clustal-omega'
- 'muscle'
- 'gblocks-bin'
- 'phyml')
-source=("http://doua.prabi.fr/software/seaview_data/seaview${pkgver: 0: 1}-64.tgz"
+ 'muscle'
+ 'gblocks'
+ 'phyml'
+ 'bionj')
+source=("https://doua.prabi.fr/software/seaview_data/seaview.tar.gz"
'seaview.desktop'
'seaview.png')
-md5sums=('64884b3237b795fb76927c61a3c2b242'
- '43fa9e52949a5cd73f202af76e2cab56'
+md5sums=('09f6800973308a91316bb820c4331cb0'
+ 'e4cfc6d76819c5cd8e68ac93c2121557'
'337583df60b24d724d96e511a3f063ce')
+build(){
+ cd $pkgname
+ make
+}
package() {
- install -d "$pkgdir"/usr/{bin,share/{seaview,applications}}
- install -m644 seaview.desktop "$pkgdir/usr/share/applications/"
- mv "$srcdir"/seaview/* "$pkgdir"/usr/share/seaview
- ln -s /usr/share/seaview/seaview "$pkgdir"/usr/bin/seaview
- install -Dm 755 "$srcdir"/seaview.png "$pkgdir"/usr/share/seaview/seaview.png
+ install -Dm 755 "$srcdir"/$pkgname/$pkgname "$pkgdir"/usr/bin/$pkgname
+ install -Dm 644 seaview.desktop $pkgdir/usr/share/applications/seaview.desktop
+ install -Dm 755 "$srcdir"/seaview.png $pkgdir/usr/share/seaview/seaview.png
}