summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD48
1 files changed, 22 insertions, 26 deletions
diff --git a/PKGBUILD b/PKGBUILD
index c3d53bf7a62f..ee5f6cf24c78 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,38 +1,34 @@
-# Maintainer: Steffen Weber <-boenki-gmx-de->
+# Maintainer: Guoyi Zhang <myname at malacology dot net>
+# Contributor: Steffen Weber <-boenki-gmx-de->
# Contributor: Nick B <Shirakawasuna at gmail _dot_com>
pkgname=seaview
-pkgver=4.7
-pkgrel=1
-pkgdesc="GUI for multiple sequence alignment and molecular phylogeny"
+pkgver=5.0.5
+pkgrel=8
+pkgdesc="GUI for multiple sequence alignment and molecular phylogeny. https://doi.org/10.1093/molbev/msp259"
arch=('x86_64')
url="http://doua.prabi.fr/software/seaview"
license=('GPL3')
-depends=('shared-mime-info' 'fltk')
-optdepends=('clustal-omega: alignment'
- 'muscle: alignment')
-source=("ftp://pbil.univ-lyon1.fr/pub/mol_phylogeny/$pkgname/archive/${pkgname}_${pkgver}.tar.gz"
+depends=('fltk')
+makedepends=('make' 'gcc' 'fltk')
+optdepends=('clustal-omega'
+ 'muscle'
+ 'gblocks'
+ 'phyml'
+ 'bionj')
+source=("https://doua.prabi.fr/software/seaview_data/seaview.tar.gz"
'seaview.desktop'
- 'seaview.sharedmimeinfo')
-md5sums=('9c1ee28e7f870b76991de17b22d7dfcb'
- '94f13509470dd69f053ffc178884e292'
- '9592a71ee55fa6edfbaddbce2d5469b9')
-
-build() {
- cd seaview
+ 'seaview.png')
+md5sums=('09f6800973308a91316bb820c4331cb0'
+ 'e4cfc6d76819c5cd8e68ac93c2121557'
+ '337583df60b24d724d96e511a3f063ce')
+build(){
+ cd $pkgname
make
}
package() {
- install -d "$pkgdir"/usr/{bin,share/{pixmaps,man/man1,applications,icons/hicolor/scalable/apps,mime/packages,doc/seaview}}
-
- install -m644 seaview.desktop "$pkgdir/usr/share/applications/"
- install -m644 seaview.sharedmimeinfo "$pkgdir/usr/share/mime/packages/seaview.xml"
-
- cd seaview
- install -m755 seaview "$pkgdir/usr/bin/"
- install -m644 seaview.xpm "$pkgdir/usr/share/pixmaps/"
- install -m644 seaview.svg "$pkgdir/usr/share/icons/hicolor/scalable/apps/"
- install -m644 seaview.html "$pkgdir/usr/share/doc/seaview/"
- install -m644 seaview.1 "$pkgdir/usr/share/man/man1/"
+ install -Dm 755 "$srcdir"/$pkgname/$pkgname "$pkgdir"/usr/bin/$pkgname
+ install -Dm 644 seaview.desktop $pkgdir/usr/share/applications/seaview.desktop
+ install -Dm 755 "$srcdir"/seaview.png $pkgdir/usr/share/seaview/seaview.png
}