summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD15
1 files changed, 12 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index dc6222e2024a..f52aedbc1c6b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,17 +1,26 @@
pkgname=seaweedfs
pkgver=1.63
-pkgrel=1
+pkgrel=2
pkgdesc="SeaweedFS is a simple and highly scalable distributed file system"
arch=('i686' 'x86_64' 'aarch64' 'armv7h' 'armv6h' 'arm')
url="https://github.com/chrislusf/seaweedfs"
license=('APACHE')
-makedepends=('go-pie')
+makedepends=('go')
source=("$pkgname-$pkgver.tar.gz::$url/archive/$pkgver.tar.gz")
sha256sums=('dcd3cb8365bacdfd01ccf8142beadc7f759139b4d7442d78eaa8e4e62ed3307d')
+export CGO_LDFLAGS="$LDFLAGS"
+export GOFLAGS="-buildmode=pie -trimpath -mod=vendor -modcacherw"
+export GOPATH="${SRCDEST:-$srcdir}"
+
+prepare() {
+ cd $pkgname-$pkgver
+ go mod vendor
+}
+
build() {
cd $pkgname-$pkgver
- make GOPATH="${SRCDEST:-$srcdir}"
+ make
}
package() {